import Foundation
let pattern = #"(?<=npm start)([^=\n]+)(?:=?)(?:['"]+)?([^\n\'\"]+)?(?:[^\S\n]?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
npm start search=test
npm start search=test, bal,sdf
npm start search=test, bal,sdf
npm start package-name
npm start package-name=test-search, 123, sdfasf
npm start search='test'
npm start search='test, bal,sdf'
npm start search='test, bal,sdf '
npm start package-name
npm start package-name='test-search, 123, sdfasf '
npm start search="test"
npm start search="test, bal,sdf"
npm start search="test, bal,sdf "
npm start package-name
npm start package-name="test-search, 123, sdfasf "
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)