$re = '/(?<=npm start)([^=\n]+)(?:=?)(?:[\'"]+)?([^\n\'\"]+)?(?:[^\S\n]?)/m';
$str = 'npm start search=test
npm start search=test, bal,sdf
npm start search=test, bal,sdf
npm start package-name
npm start package-name=test-search, 123, sdfasf
npm start search=\'test\'
npm start search=\'test, bal,sdf\'
npm start search=\'test, bal,sdf \'
npm start package-name
npm start package-name=\'test-search, 123, sdfasf \'
npm start search="test"
npm start search="test, bal,sdf"
npm start search="test, bal,sdf "
npm start package-name
npm start package-name="test-search, 123, sdfasf "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);