const regex = /(?<=npm start)([^=\n]+)(?:=?)(?:['"]+)?([^\n\'\"]+)?(?:[^\S\n]?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=npm start)([^=\\n]+)(?:=?)(?:[\'"]+)?([^\\n\\\'\\"]+)?(?:[^\\S\\n]?)', 'gm')
const str = `npm start search=test
npm start search=test, bal,sdf
npm start search=test, bal,sdf
npm start package-name
npm start package-name=test-search, 123, sdfasf
npm start search='test'
npm start search='test, bal,sdf'
npm start search='test, bal,sdf '
npm start package-name
npm start package-name='test-search, 123, sdfasf '
npm start search="test"
npm start search="test, bal,sdf"
npm start search="test, bal,sdf "
npm start package-name
npm start package-name="test-search, 123, sdfasf "`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}