#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^CN=.+?(?<!\\),"
Local $sString = "CN=example,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup" & @CRLF & _
"CN=exa\,mple,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)