const regex = new RegExp('^CN=.+?(?<!\\\\),', 'gm')
const str = `CN=example,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup
CN=exa\\,mple,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);