import re
regex = re.compile(r"^CN=.+?(?<!\\),", flags=re.MULTILINE)
test_str = ("CN=example,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup\n"
"CN=exa\\,mple,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)