import Foundation
let pattern = #"^CN=.+?(?<!\\),"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CN=example,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup
CN=exa\,mple,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)