using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":[\d\w]+";
string input = @"test2@gmail.com:123456
test2@hotmail.com:124554134
test1@yahoo.com:fdsfsdfe
test5@gmail.com:9875464";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}