import re
regex = re.compile(r":[\d\w]+")
test_str = ("test2@gmail.com:123456\n"
"test2@hotmail.com:124554134\n"
"test1@yahoo.com:fdsfsdfe\n"
"test5@gmail.com:9875464")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")