$re = '/:[\d\w]+/';
$str = 'test2@gmail.com:123456
test2@hotmail.com:124554134
test1@yahoo.com:fdsfsdfe
test5@gmail.com:9875464';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);