import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":[\\d\\w]+";
final String string = "test2@gmail.com:123456\n"
+ "test2@hotmail.com:124554134\n"
+ "test1@yahoo.com:fdsfsdfe\n"
+ "test5@gmail.com:9875464";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}