using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sm)Modifications\s*((?!Modifications\s*).)*";
string input = @"99645,
\Submitted',
'\Modifications made 2015/01/01',
'change0: --> info0',
'change1: --> info1',
'change2: --> info2',
'change3: --> info3',
'\Modifications made 2015/01/03',
'\Modifications made 2015/01/05',
'\Modifications made 2015/01/07',
'change0: --> info0',
'change1: --> info1',
'\Modifications made 2015/01/07',";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}