const regex = new RegExp('(?sm)Modifications\\s*((?!Modifications\\s*).)*', 'g')
const str = `99645,
\\Submitted',
'\\Modifications made 2015/01/01',
'change0: --> info0',
'change1: --> info1',
'change2: --> info2',
'change3: --> info3',
'\\Modifications made 2015/01/03',
'\\Modifications made 2015/01/05',
'\\Modifications made 2015/01/07',
'change0: --> info0',
'change1: --> info1',
'\\Modifications made 2015/01/07',`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}