use strict;
my $str = '99645,
\\Submitted\',
\'\\Modifications made 2015/01/01\',
\'change0: --> info0\',
\'change1: --> info1\',
\'change2: --> info2\',
\'change3: --> info3\',
\'\\Modifications made 2015/01/03\',
\'\\Modifications made 2015/01/05\',
\'\\Modifications made 2015/01/07\',
\'change0: --> info0\',
\'change1: --> info1\',
\'\\Modifications made 2015/01/07\',';
my $regex = qr/(?sm)Modifications\s*((?!Modifications\s*).)*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}