import re
regex = re.compile(r"(?sm)Modifications\s*((?!Modifications\s*).)*")
test_str = ("99645,\n"
"\\Submitted',\n"
" '\\Modifications made 2015/01/01',\n"
" 'change0: --> info0',\n"
" 'change1: --> info1',\n"
" 'change2: --> info2',\n"
" 'change3: --> info3',\n"
" '\\Modifications made 2015/01/03',\n"
" '\\Modifications made 2015/01/05',\n"
" '\\Modifications made 2015/01/07',\n"
" 'change0: --> info0',\n"
" 'change1: --> info1',\n"
" '\\Modifications made 2015/01/07',")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")