import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)Modifications\\s*((?!Modifications\\s*).)*";
final String string = "99645,\n"
+ "\\Submitted',\n"
+ " '\\Modifications made 2015/01/01',\n"
+ " 'change0: --> info0',\n"
+ " 'change1: --> info1',\n"
+ " 'change2: --> info2',\n"
+ " 'change3: --> info3',\n"
+ " '\\Modifications made 2015/01/03',\n"
+ " '\\Modifications made 2015/01/05',\n"
+ " '\\Modifications made 2015/01/07',\n"
+ " 'change0: --> info0',\n"
+ " 'change1: --> info1',\n"
+ " '\\Modifications made 2015/01/07',";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}