import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!s\\.|l\\.|nd|et) [0-9]+";
final String string = "Art. 19 Cst.\n"
+ "§ 39 VG\n"
+ "§ 39 Abs. 1 und 2 VG\n"
+ "Art. 19 BV\n"
+ "Art. 62 Abs. 1 BV\n"
+ "Art. 13 UNO-Pakt I\n"
+ "Art. 14 KV/ZH";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}