use strict;
my $str = 'Art. 19 Cst.
§ 39 VG
§ 39 Abs. 1 und 2 VG
Art. 19 BV
Art. 62 Abs. 1 BV
Art. 13 UNO-Pakt I
Art. 14 KV/ZH';
my $regex = qr/(?<!s\.|l\.|nd|et) [0-9]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}