import Foundation
let pattern = #"(?<!s\.|l\.|nd|et) [0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Art. 19 Cst.
§ 39 VG
§ 39 Abs. 1 und 2 VG
Art. 19 BV
Art. 62 Abs. 1 BV
Art. 13 UNO-Pakt I
Art. 14 KV/ZH
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)