import re
regex = re.compile(r"(?<!s\.|l\.|nd|et) [0-9]+", flags=re.MULTILINE)
test_str = ("Art. 19 Cst.\n"
"§ 39 VG\n"
"§ 39 Abs. 1 und 2 VG\n"
"Art. 19 BV\n"
"Art. 62 Abs. 1 BV\n"
"Art. 13 UNO-Pakt I\n"
"Art. 14 KV/ZH")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")