$re = '/(?<!s\.|l\.|nd|et) [0-9]+/m';
$str = 'Art. 19 Cst.
§ 39 VG
§ 39 Abs. 1 und 2 VG
Art. 19 BV
Art. 62 Abs. 1 BV
Art. 13 UNO-Pakt I
Art. 14 KV/ZH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);