const regex = new RegExp('(?<!s\\.|l\\.|nd|et) [0-9]+', 'gm')
const str = `Art. 19 Cst.
§ 39 VG
§ 39 Abs. 1 und 2 VG
Art. 19 BV
Art. 62 Abs. 1 BV
Art. 13 UNO-Pakt I
Art. 14 KV/ZH`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}