#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sx)("|') # match a single or double quote and put it in group 1" & @CRLF & _
".*? # match anything ungreedy until ..." & @CRLF & _
"\1 # match what was matched in group 1 " & @CRLF & _
"| # or" & @CRLF & _
"[^,\s]+ # match anything except white-space and comma one or more times"
Local $sString = "apple, banana, pineapple, "tropical fruits like mango, guava, key lime", peaches, 'kiwi, tomato', fruits"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")