using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""|') # match a single or double quote and put it in group 1
.*? # match anything ungreedy until ...
\1 # match what was matched in group 1
| # or
[^,\s]+ # match anything except white-space and comma one or more times";
string input = @"apple, banana, pineapple, ""tropical fruits like mango, guava, key lime"", peaches, 'kiwi, tomato', fruits";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}