$re = '/("|\') # match a single or double quote and put it in group 1
.*? # match anything ungreedy until ...
\1 # match what was matched in group 1
| # or
[^,\s]+ # match anything except white-space and comma one or more times/sx';
$str = 'apple, banana, pineapple, "tropical fruits like mango, guava, key lime", peaches, \'kiwi, tomato\', fruits';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);