package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)("|') # match a single or double quote and put it in group 1
.*? # match anything ungreedy until ...
\1 # match what was matched in group 1
| # or
[^,\s]+ # match anything except white-space and comma one or more times`)
var str = `apple, banana, pineapple, "tropical fruits like mango, guava, key lime", peaches, 'kiwi, tomato', fruits`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}