# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
("|') # match a single or double quote and put it in group 1
.*? # match anything ungreedy until ...
\1 # match what was matched in group 1
| # or
[^,\s]+ # match anything except white-space and comma one or more times
"""
test_str = "apple, banana, pineapple, \"tropical fruits like mango, guava, key lime\", peaches, 'kiwi, tomato', fruits"
matches = re.finditer(regex, test_str, re.DOTALL | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.