use strict;
my $str = 'apple, banana, pineapple, "tropical fruits like mango, guava, key lime", peaches, \'kiwi, tomato\', fruits';
my $regex = qr/("|') # match a single or double quote and put it in group 1
.*? # match anything ungreedy until ...
\1 # match what was matched in group 1
| # or
[^,\s]+ # match anything except white-space and comma one or more times/sxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}