import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"|') # match a single or double quote and put it in group 1\n"
+ ".*? # match anything ungreedy until ...\n"
+ "\\1 # match what was matched in group 1 \n"
+ "| # or\n"
+ "[^,\\s]+ # match anything except white-space and comma one or more times";
final String string = "apple, banana, pineapple, \"tropical fruits like mango, guava, key lime\", peaches, 'kiwi, tomato', fruits";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}