#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\(\d+\)\s?\d*|\d+)([-\/ ]\d+){1,3}"
Local $sString = "800-569-0123," & @CRLF & _
"1-866-523-4176," & @CRLF & _
"(324)442-9843," & @CRLF & _
"(212) 332-1200," & @CRLF & _
"713/853-5620," & @CRLF & _
"713 853-0357," & @CRLF & _
"713 837 1749,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")