import re
regex = re.compile(r"(?:\(\d+\)\s?\d*|\d+)([-\/ ]\d+){1,3}")
test_str = ("800-569-0123,\n"
"1-866-523-4176,\n"
"(324)442-9843,\n"
"(212) 332-1200,\n"
"713/853-5620,\n"
"713 853-0357,\n"
"713 837 1749,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")