using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\(\d+\)\s?\d*|\d+)([-\/ ]\d+){1,3}";
string input = @"800-569-0123,
1-866-523-4176,
(324)442-9843,
(212) 332-1200,
713/853-5620,
713 853-0357,
713 837 1749,";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}