re = /(?:\(\d+\)\s?\d*|\d+)([-\/ ]\d+){1,3}/
str = '800-569-0123,
1-866-523-4176,
(324)442-9843,
(212) 332-1200,
713/853-5620,
713 853-0357,
713 837 1749,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end