package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\(\d+\)\s?\d*|\d+)([-\/ ]\d+){1,3}`)
var str = `800-569-0123,
1-866-523-4176,
(324)442-9843,
(212) 332-1200,
713/853-5620,
713 853-0357,
713 837 1749,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}