import Foundation
let pattern = #"(?:\(\d+\)\s?\d*|\d+)([-\/ ]\d+){1,3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
800-569-0123,
1-866-523-4176,
(324)442-9843,
(212) 332-1200,
713/853-5620,
713 853-0357,
713 837 1749,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)