#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!ABC)(?<!\d)\d+"
Local $sString = "sdkfjsd 12312981 sdkfjsdfhbnmawd 1298 ,smdfsdnfk2342423 " & @CRLF & _
"sdlkfsdfs 20349 ABC1203912 2034234aac <-- ABC<number> stays, the other numbers do not" & @CRLF & _
"ABC1203912"
Local $sSubst = "#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)