re = /(?<!ABC)(?<!\d)\d+/
str = 'sdkfjsd 12312981 sdkfjsdfhbnmawd 1298 ,smdfsdnfk2342423
sdlkfsdfs 20349 ABC1203912 2034234aac <-- ABC<number> stays, the other numbers do not
ABC1203912'
subst = '#'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result