import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!ABC)(?<!\\d)\\d+";
final String string = "sdkfjsd 12312981 sdkfjsdfhbnmawd 1298 ,smdfsdnfk2342423 \n"
+ "sdlkfsdfs 20349 ABC1203912 2034234aac <-- ABC<number> stays, the other numbers do not\n"
+ "ABC1203912";
final String subst = "#";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}