# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!ABC)(?<!\d)\d+"
test_str = ("sdkfjsd 12312981 sdkfjsdfhbnmawd 1298 ,smdfsdnfk2342423 \n"
"sdlkfsdfs 20349 ABC1203912 2034234aac <-- ABC<number> stays, the other numbers do not\n"
"ABC1203912")
subst = "#"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.