import Foundation
let pattern = #"(?<!ABC)(?<!\d)\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
sdkfjsd 12312981 sdkfjsdfhbnmawd 1298 ,smdfsdnfk2342423
sdlkfsdfs 20349 ABC1203912 2034234aac <-- ABC<number> stays, the other numbers do not
ABC1203912
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)