const regex = /(?<!ABC)(?<!\d)\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!ABC)(?<!\\d)\\d+', 'g')
const str = `sdkfjsd 12312981 sdkfjsdfhbnmawd 1298 ,smdfsdnfk2342423
sdlkfsdfs 20349 ABC1203912 2034234aac <-- ABC<number> stays, the other numbers do not
ABC1203912`;
const subst = `#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);