using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!ABC)(?<!\d)\d+";
string substitution = @"#";
string input = @"sdkfjsd 12312981 sdkfjsdfhbnmawd 1298 ,smdfsdnfk2342423
sdlkfsdfs 20349 ABC1203912 2034234aac <-- ABC<number> stays, the other numbers do not
ABC1203912";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}