# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,\s*(?=[^,]*=)/", "/gm;t' <<< "{Object1=Text Goes Right Here, and Here, Object2 = Another Text Here}
"