re = /,\s*(?=[^,]*=)/m
str = '{Object1=Text Goes Right Here, and Here, Object2 = Another Text Here}
'
subst = '", "'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result