using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",\s*(?=[^,]*=)";
string substitution = @""", """;
string input = @"{Object1=Text Goes Right Here, and Here, Object2 = Another Text Here}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}