import Foundation
let pattern = #",\s*(?=[^,]*=)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{Object1=Text Goes Right Here, and Here, Object2 = Another Text Here}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"", ""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)