use strict;
my $str = '{Object1=Text Goes Right Here, and Here, Object2 = Another Text Here}
';
my $regex = qr/,\s*(?=[^,]*=)/mp;
my $subst = '", "';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";