#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m),\s*(?=[^,]*=)"
Local $sString = "{Object1=Text Goes Right Here, and Here, Object2 = Another Text Here}" & @CRLF & _
""
Local $sSubst = "", ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)