$re = '/,\s*(?=[^,]*=)/m';
$str = '{Object1=Text Goes Right Here, and Here, Object2 = Another Text Here}
';
$subst = "\", \"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;