const regex = /(?:\s*<br[^>]*>\s*){3,}/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*<br[^>]*>\\s*){3,}', 'sg')
const str = `<br>
<br>
<br>
High Quality Print<br>
<br><br>
<br><br>
<br>
Data<br>
<br>
<br>
<br>`;
const subst = `<br><br>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);